17 lines
430 B
Nix
17 lines
430 B
Nix
{ config, pkgs, ... }:
|
|
|
|
{
|
|
boot.binfmt = {
|
|
registrations.appimage = {
|
|
wrapInterpreterInShell = false;
|
|
interpreter = "${pkgs.appimage-run}/bin/appimage-run";
|
|
recognitionType = "magic";
|
|
offset = 0;
|
|
mask = "\\xff\\xff\\xff\\xff\\x00\\x00\\x00\\x00\\xff\\xff\\xff";
|
|
magicOrExtension = "\\x7fELF....AI\\x02";
|
|
};
|
|
# run aarch64 binaries
|
|
emulatedSystems = [ "aarch64-linux" ];
|
|
};
|
|
}
|